Ошибка при записи фичи: Невалидный сертификат

Страницы: 1
RSS
Ошибка при записи фичи: Невалидный сертификат
 
Здравствуйте.

Давно не прописывал ключей и вот на днях стал прописывать фичи в новый ключ. Запустил EMS - Entitlements - выбрал продукт - "включил" его в ключ - нажал Produce. Возникла Java-ошибка. Поковырялся, оказывается сертификат Sentinel истек в конце 2016 года. Обратился в ближайшему дистрибьютеру (Алматы), они прислали мне ссылку на скачивание дистрибутива, мол, "переустановите".  Нельзя ли просто получить новый сертификат от Sentinel и установить его?
EMS : 7.XX
Hasp-ключи: 3.25

С уважением,
Марк
 
Добрый день, Марк.

Сертификат отдельно не распространяется, только в составе самого SDK. Если я правильно понимаю, то Вы не обновляли SDK более 5 лет, поэтому в любом случае мы настоятельно рекомендуем обновить SDK до актуальной версии. Там и новые возможности, и поддержка современных ОС и меньше зависимости от Java при работе с SDK.
Актуальная версия LDK 7.10: https://safenet-sentinel.ru/helpdesk/
 
Спасибо. 2 вопроса:

1. при обновлении версии EMS не поменяется Vendor Code (который в файле находится ХХХХХ.hvc) и соответственно dll (hasp_windows_XXXXXX.dll)?

2. Sentinel-софт и Java: соответствие версий? можно ли обновлять Java? (я держу на этой машине старую-старую Java (точно не помню версию) и не даю ей обновляться) :)

Спасибо  
 
1. При обновлении не поменяется. Поменяется если запустите заново утилиту MasterWizard. Но это не страшно, ранее сгенерированные файлы не перестанут от этого работать.

2. Можете обновлять :)  
В случае чего - вот инструкция как все починить - https://safenet-sentinel.ru/faq/dev/sentinel/ems/#6466
Страницы: 1
Читают тему (гостей: 1)