XP усё?

Страницы: 1
RSS
XP усё?, XP больше не поддерживается?
 
При попытке запустить HASPUserSetup.exe под Windows XP выдаётся сообщение, что операционная система не поддерживается. Это надо понимать, что на работе под XP ставится крест?

Уж больно много клиентов используют XP при работе с сетевыми HASP...

P.S. Обходной путь с haspdinst.exe я знаю
 
Добрый день, Игорь.

Да, поддержка Windows XP в актуальных версия драйверов (всех драйверов: и HASPUserSetup.exe, и haspdinst.exe тоже) больше не осуществляется. А также, при защите ПО современной версией SDK LDK (7.8 и выше), мы не гарантируем работу таких приложений на Windows XP.
Рано или поздно это должно было случиться, особенно если учесть что сама Microsoft уже с 2014 года полностью перестала поддерживать Windows XP.

Реально есть только один вариант решения: для защиты приложений, которые должны работать под Windows XP, использовать SDK LDK  версии 7.6 и ниже, а на стороне клиента, драйвера версии ниже чем 7.80.
 
https://sentinelcustomer.gemalto.com/sentineldownloads/?s=&c=all&p=all&o=all&t=Runtime+%26+Device+Driver&l=all - вот тут версии runtime 7.54 просто нету.

Раньше была - раньше ВСЕ версии были, а теперь там версия рантайма 5.х - это же вообще насмешка

В общем, большой привет пользователям...


Цитата
Игорь Губин пишет:
Обходной путь с haspdinst.exe я знаю
это какой ? просто устанавливать его, или там какие-то хитрые ключи есть ?
 
Цитата
Дмитрий Буров пишет:
Игорь Губин пишет:
Обходной путь с haspdinst.exe я знаюэто какой ? просто устанавливать его
UPD: да, именно так, этот пакет на XP устанавливается, пока
 
Игорь Губин, такой вопрос. Вы можете посмотреть на те рабочие станции XP/2003, где вам удалось поставить новые версия драйвера?

У нас один клиент ставил 7.8x cmdline на XP, успешно
Другой попробовал поставить 7.90 cmdline на 2003 - и установка обломалась из-за нехватки


RstrtMgr.DLL

Интернет говорит, что эта DLL появилась в Vista SP1 (внезапно - совпадекние с readme от Runtime)
Но не факт, что её задним числом не бэкпортировали в XP/2003 или в Vista no-SP

Кроме того, интернет вроде говорит, её как GDI+ - вполне можно с новых Windows скопировать на старую и сделать regsvr32

Распаковка 7.81 cmdline - нет в ней этой DLL
А вот 7.80 cmdline у меня нету, проверить не могу.

Т.е. получается, либо в 7.81 или 7.80 cmdline ещё не требовалось, либо она каким-то образом уже была на комьпютере с XP. Интересно....
 
Господа, где скачать SDK LDK  версии 7.6 и ниже, и драйвера версии ниже чем 7.80.

Клиентов и правда полно использующих WinXP и более того есть необходимые программы которые пишутся исключительно под FrameWork 3.5.

Дайте ссылки пожалуйста.
 
Цитата
necro3078 пишет:
Господа, где скачать SDK LDK версии 7.6 и ниже, и драйвера версии ниже чем 7.80.

Клиентов и правда полно использующих WinXP и более того есть необходимые программы которые пишутся исключительно под FrameWork 3.5.

Дайте ссылки пожалуйста.
нашел сам. вопрос закрыт
Страницы: 1
Читают тему (гостей: 2)