Не работает HL Pro в Linux Debian amd64

Страницы: 1
RSS
Не работает HL Pro в Linux Debian amd64
 
Добрый день, есть следующая проблема:
ОС Debian Stretch amd64, поднят aksusbd 7.51, ПО работает через hasp api.
При первом физическом подключении ключа HL Pro все работает корректно.
После того, как ключ был физически удален (из разъема USB),
потом подключен снова (не важно, тот ли это ключ, или другой),
вызов hasp_login всегда возвращает HASP_HASP_NOT_FOUND (7).
Помогает перезапуск aksusbd .
Подскажите, куда копать?
Спасибо.
 
Добрый день, Виталий.
Цитата
Виталий Аметов пишет:
поднят aksusbd 7.51
Первое что стоит попробовать - использовать актуальную версию нашего драйвера - 7.61, скачать можно тут:
https://sentinelcustomer.gemalto.com/sentineldownloads/?s=&c=Software+Developer&p=Sentinel+LDK&o=all&t=Runtime+%26+D­evice+Driver&l=all
 
Обновил до 7.61 (Run-time Installer  7.61, aksusbd  7.60), проблема осталась
 
Виталий, пришлите результаты вывода команды: uname -a  
 
Пожалуйста
Linux FalconOffice 4.12.0-2-amd64 #1 SMP Debian 4.12.13-1 (2017-09-19) x86_64 GNU/Linux
 
Виталий, как я понимаю, Вы используете ОС с одной из последних версий ядра: 4.12.х
У нас в списке официально поддерживаемых систем значится: Debian 8.x - там ядра были 3.16 - 4.0.
Подобная конфигурация ОС (как у Вас) не тестировалась нашими специалистами в связке с RTE, и потому её нет в списке официально поддерживаемых дистрибутивов.

Используйте дистрибутив из списка официально поддерживаемых:
http://sentinelldk.safenet-inc.com/LDKdocs/RN/Content/ReleaseNotes/130-Supported_Platforms_for_Sentinel.htm
 
Переход на другую версию ОС для нас  - не самое удачное решение проблемы. Этой версии Debian уже полгода, планируете ли вы добавить ее в список поддерживаемых, и если да, то когда?
Пока в качестве заплатки подправили правило udev для перезапуска aksusbd при подключении ключа.
 
Виталий, а что у Вас за ключ? Какая у него микропрошивка?
Цитата
Виталий Аметов пишет:
Этой версии Debian уже полгода, планируете ли вы добавить ее в список поддерживаемых, и если да, то когда?
Мы периодически добавляем новые версии ОС к списку официально поддерживаемых, однако планов на добавление указанной Вами сборки я не вижу пока в нашем RoadMap.
 
У нас много ключей, последние купленные (в новом корпусе) имеют версии 4.27 или 4.31
Остались даже в старом корпусе, с версиями 325-61 и 3.25. Со всеми ключами одинаковое поведение.
В Windows7 x64 все работает нормально, кстати
 
Виталий,
Цитата
Виталий Аметов пишет:
В Windows7 x64 все работает нормально, кстати
Драйвер под Linux и драйвер под Windows сравнивать разумеется не корректно, это разные платформы.

Цитата
Виталий Аметов пишет:
Со всеми ключами одинаковое поведение.
В таком случае, к сожалению, пока более ничего порекомендовать не могу.
Страницы: 1
Читают тему (гостей: 1)